Unable to mount samba share in Clonezilla

By | January 30, 2016

Sometimes Clonezilla won’t let me mount a shared folder on my laptop running Windows 7 so I decided to find out why and fix it.

My laptop is an Active Directory domain member and I was using a cross-over cable to connect it to the laptop I wanted to backup. Also the domain was not available at the time (I was offline) so Icreated a local useraccount on my laptop and gave it change rights on the target folder. Then Ishared the target folder and gave the new account change rights.

For the occasion I turned off my Windows firewall.

From the Clonezilla menu I entered the command prompt and tried a whole bunch of mount syntax possibilities. This was the one that worked:

$ sudo mount -t cifs //10.0.0.1/carolien /home/partimag
-o rw,username=carolien,password=p455w0rd

(The above text is one line; I split it in two lines to keep it readable. Obviously, change the username and the password to your own.)

Using the computername of my laptop in lower case as the domain name also seems to work but not always.

After the Windows 7 laptop hibernated and I tried it again, Clonezilla said:

cifs_mount failed w/return code = -12

This site gave me the solution:

In

HKLM\SYSTEM\CurrentControlSet\Control\
Session Manager\Memory Management\LargeSystemCache

change the value to 3 and then stop and restart the server service:

net stop server
net start server

On another occasion I got this error:

cifs_mount failed w/return code = -5

Recreating the share on the Windows host helped.

Сomments аrchive